Find a repair centre

Support & Downloads: Epson Stylus Photo R2000

EPSON Network Utility: Privilege Vulnerability

RELATES TO:

  • Epson Network utility
  • Operating Systems:
    • Windows 2000
    • Windows XP
    • Windows Vista
    • Windows 7
    • Windows 8
    • Windows 10
    • Windows Server 2003
    • Windows Server 2008 / 2008 R2

Explanation:

The EPSON Network utility included with some older Epson printers installs a binary with weak permissions, which can allow a low privilege user to increase their privileges and take control of the system.

Impact:

Successful exploitation of this vulnerability can lead to unauthorised control of the system by a low privilege user. Epson is not aware of any reported incidents to date.

Affected Models - Click Here

AcuLaser AL-C9200, AL-CX11, AL-CX21, AL-M2000, AL-M2300, AL-M2400, AL-M4000, AL-M8000, AL-MX20
Business Inkjet B-310N, B-500DN, B-510DN
Expression Home XP-202, XP-205, XP-302, XP-305, XP-402, XP-405
Expression Premium XP-600, XP-605, XP-700, XP-800
Retail Technology ColorWorks C3400, ColorWorks C3500, ColorWorks GP-C831, GP-M831, TM-C610, TM-C710
Stylus Office B40W, BX305F, BX305FW Plus, BX310FN, BX320FW, BX525WD, BX600FW, BX610FW, BX625FWD, BX925FWD
Stylus Photo 1500W, 2100, R1800, R2000, R2400, R3000, PX700W, PX710W, PX720WD, PX730WD, PX820FWD, PX830FWD
Stylus Pro 10600, 11880, 3800, 3880, 4000, 4400, 4450, 4800, 4880, 4900, 7400, 7450, 7600, 7700, 7800, 7880, 7890, 7900, 9400, 9450, 9600, 9700, 9800, 9880, 9890, 9900, GS6000, WT7900
Epson Stylus SX SX235W, SX425W, SX510W, SX515W, SX535WD, SX600FW, SX610FW, SX620FW,

Solution:

To resolve this and to ensure the security of your Epson software, please click here to download and install the latest version of the EPSON Network utility.

Did you find this article helpful

Thanks for leaving feedback